1. Уважаемый Гость! При написании вопросов в раздел форума [ArduCopter] Вопросы, проблемы и решения обязательно придерживаться шаблона сообщения, оговоренного в правилах раздела! Если сообщение не будет оформлено должным образом, то и ответ на вопрос будет с наименьшим приоритетом. Старайтесь дать максимально полную информацию по вашей проблеме, чтобы можно было более детально рассматривать вопрос!
    Скрыть объявление
  2. Уважаемый Гость! Хотите получить 200р за регистрацию? Хотите получать кэшбэк с покупок в online-магазинах? Сервис "LetyShops" дает такую возможность!
    Скрыть объявление
  3. Друзья! Для нашего ресурса необходим дополнительный объем пространства в облаке Dropbox. Подробнее.
    Скрыть объявление

Storm32 зависание подвеса

Тема в разделе "Оборудование FPV, телеметрия, фото/видео", создана пользователем Alex37, 18 янв 2019.

  1. Alex37

    Alex37 Абитуриент

    Регистрация:
    20 май 2018
    Сообщения:
    7
    Город:
    Иваново
    Имя:
    Алексей
    Привет всем . Подвес STORM 32 V1.3 китайский естественно с Али, стал периодически зависать , движки тупо фиксировались или начинался расколбас. Причём вычислить логику появления этого дефекта не удавалось. Подвес стабильно мог работать и 5 минут или затупить сразу. Но один раз поймал этот глюк в GUI и там ошибка IMU высветилась. Заменил гиру на новый датчик, та же ерунда.
    В общем всю голову сломал , скурил весь форум официалов.
    Варианта 2 это помехи и проблемы с питанием IMU.

    Начал с помех.... развел все провода подальше от датчика , феррит на I2C поставил - не помогло.
    Запитал плату не с UBECa , а прямо с аккума - не помогло.
    Холод, тепло , так же не влияют на работу IMU . Внешних помех нет.

    Добрался до питания ...... как не хотелось. На Плате СТАБИЛИЗАТОР на 3.3 в. На выходе 3.24 заменил на AMS 1117 стало 3.32 В. Стало вроде лучше , реже виснуть, но в целом так же беда.

    По проводам (целые )добрался до нижнего датчика IMU , на нем свой стаб на 3.3 в для чего не понятно, ведь с платы уже идет 3.3 в. По даташиту стаб в плате IMU с 5в на 3.3в. Подкинул на стаб IMU 5в от дополнительной AMSки. Не помогло...... стало грустно .....куда копать..... с горя заказал рем комплект плату с гиро.

    Вчера пришёл комплект . Чип такой же как и на старом датчике , и стабилизатор там тоже есть но другая микросхема. Подключил датчик , даже не калибровал, и это чудо техники заработало.

    Снял феррит, подключил плату с UBECA, провода скрутил с проводами движков. 2 дня ни одного глюка, ни зависаний , ни подергиваний......
    Вопрос ЧТО это было.

    Фото датчиков прилагаю , новый который с дырками под крепление часто фигурирует на фото официалов.
     

    Вложения:

    Последнее редактирование: 21 янв 2019
  2. Alex37

    Alex37 Абитуриент

    Регистрация:
    20 май 2018
    Сообщения:
    7
    Город:
    Иваново
    Имя:
    Алексей
    В общем пошла 3 неделя , работы нет пока ...... буду мучать STORM 32. Нашёл таки закономерность в настройках PID регулятора, видео с ютуба только больше запутали. Офф сайт Olliw , внёс
    небольшую ясность , но там всё по не нашему . Нашёл таки золотую середину !!!! Пока от подвеса я в полном восторге. Когда получил его , не настраивал, поставил как есть и полетел. И вроде бы видео меня устраивало,
    но сейчас когда я настроил должным образом, это прямо небо и земля. Всё таки от безработицы есть польза, тыкая неделю в PID ы, записывая в тетрадочку показания , замеряя температуру двигателей, и анализируя видео
    принесли свои плоды. Если снятое видео меня и всех устроит расскажу что да как делал.